Wednesday, 2014-09-24

warthog9GPSFan: ok I've got my install up00:00
warthog9GPSFan: I booted 17, the one we mentioned, did an install to my usb enclosure / disk00:00
warthog9before I rebooted from the install I edited grub00:00
warthog9pulled the install disk out, rebooted00:01
warthog9and the system came right up00:01
*** prpplague <prpplague!~prpplague@rrcs-97-77-26-26.sw.biz.rr.com> has quit IRC00:10
*** hrw <hrw!~hrw@redhat/hrw> has quit IRC00:13
*** hrw <hrw!~hrw@redhat/hrw> has joined #minnowboard00:14
*** Agustin67 <Agustin67!~nodebot@li604-225.members.linode.com> has joined #minnowboard00:49
*** sjolley <sjolley!sjolley@nat/intel/x-qviuqjmphkxegpsu> has joined #minnowboard00:52
*** prpplague <prpplague!~prpplague@107-206-64-184.lightspeed.rcsntx.sbcglobal.net> has joined #minnowboard01:23
*** Agustin67 <Agustin67!~nodebot@li604-225.members.linode.com> has quit IRC01:25
*** inflex <inflex!~PLD@122-148-142-6.static.dsl.dodo.com.au> has quit IRC01:26
*** inflex <inflex!~PLD@122-148-142-6.static.dsl.dodo.com.au> has joined #minnowboard01:27
*** Audreanne84 <Audreanne84!~nodebot@li604-225.members.linode.com> has joined #minnowboard01:42
*** IoGA_ <IoGA_!~ioga@ec2-23-23-195-205.compute-1.amazonaws.com> has quit IRC02:11
GPSFanwarthog9, well, that's actually a relief, since the problem is with either my install, or the goflex. I only have one usb3 disk so I can't try it on another hdd for a while. Thanks a lot for your effort. I'd still like to figure out what's wrong, but it is not now a critical issue.02:23
GPSFanmaybe I'll try another from scratch install tomorrow.02:24
GPSFanwarthog9, did you have to choose the correct disk in the bios/uefi, and were you using .71 firmware (you said you were testing .73 some days ago)?02:29
GPSFanwarthog9, and lastly, what rev of the MinnowMax were you using? any cpu/soc differences, mine is an A1 (3214MMAX0590)02:32
*** Audreanne84 <Audreanne84!~nodebot@li604-225.members.linode.com> has quit IRC02:38
*** Aurelia3 <Aurelia3!~nodebot@li604-225.members.linode.com> has joined #minnowboard02:49
*** GPSFan <GPSFan!~kenm@64.92.145.112> has quit IRC02:57
*** smurray <smurray!~Scott@135-23-64-25.cpe.pppoe.ca> has quit IRC03:19
*** smurray <smurray!~Scott@135-23-64-25.cpe.pppoe.ca> has joined #minnowboard03:22
*** aholler <aholler!~aholler@p4FC36802.dip0.t-ipconnect.de> has joined #minnowboard03:30
*** aholler_ <aholler_!~aholler@p4FC36A07.dip0.t-ipconnect.de> has quit IRC03:33
*** Aurelia3 <Aurelia3!~nodebot@li604-225.members.linode.com> has quit IRC03:39
*** Alanna59 <Alanna59!~selbyk@li604-225.members.linode.com> has joined #minnowboard03:42
*** holtmann is now known as Guest2698904:12
*** Alanna59 <Alanna59!~selbyk@li604-225.members.linode.com> has quit IRC04:18
*** Guest26989 is now known as holtmann04:46
*** hrww <hrww!~hrw@redhat/hrw> has joined #minnowboard05:45
*** hrw <hrw!~hrw@redhat/hrw> has quit IRC05:47
*** hrww is now known as hrw05:47
*** macmeck <macmeck!~macmeck@212.172.46.34> has joined #minnowboard06:56
*** macmeck <macmeck!~macmeck@212.172.46.34> has quit IRC07:05
*** bluelightning <bluelightning!~paul@pdpc/supporter/professional/bluelightning> has joined #minnowboard07:23
*** bluelightning <bluelightning!~paul@pdpc/supporter/professional/bluelightning> has quit IRC08:59
*** bluelightning <bluelightning!~paul@pdpc/supporter/professional/bluelightning> has joined #minnowboard08:59
*** Jazzdude <Jazzdude!6dc03c5d@gateway/web/freenode/ip.109.192.60.93> has joined #minnowboard10:08
*** macmeck <macmeck!~macmeck@212.172.46.34> has joined #minnowboard12:23
macmeckprpplague: i had a look at the schematics of the seacat lure. isn't J7 the jumper to power on the mPCIe socket even if the card type pin isn't configured correctly?12:27
* seaLne wonders why his max won't boot anymore13:05
seaLneafter power on the second led and the pendrive led come on for a couple of seconds then they go off and the current consumption drops to only a few mA13:06
seaLnehaving hdmi or kbd/mouse connected makes no differenc. the power to the usb2 port which has the kbd/mouse conected via a hub never seems to get power either. the boot pendrive is usb313:08
seaLnehmm now my other max isn't booting either i wonder if its that psu13:16
seaLneweird i'm sure i used that psu before, but looks like that was the problem. so maybe thats the behaviour when there isn't enough current?13:21
*** macmeck <macmeck!~macmeck@212.172.46.34> has quit IRC13:24
JazzdudeseaLne: I used a 1.5A psu with my minnowboard and haven't seen any problems, even though 2.5A is recommended14:08
seaLnethat was with a 2A bench psu that i have used before...14:23
*** prpplague <prpplague!~prpplague@107-206-64-184.lightspeed.rcsntx.sbcglobal.net> has quit IRC14:24
seaLnebut switching to a 3A wallwart got it too boot instantly14:26
BhaalMouser still don't have stock of Max?  Is it that popular that CircuitCo can't keep up? :)14:44
seaLneBhaal: did you get anywhere with clock and battery?14:48
BhaalseaLne: I haven't even fired the Max up since then, been working on some other projects, but its coming out to play this weekend, and then I need to push it into service full time next week14:49
BhaalIt needs to earn me some money14:49
seaLneyeah i've been busy with other things the last few weeks aswell14:50
BhaalCircuitCo are still making htem right?14:50
*** inflex <inflex!~PLD@122-148-142-6.static.dsl.dodo.com.au> has quit IRC14:51
*** sjolley <sjolley!sjolley@nat/intel/x-qviuqjmphkxegpsu> has quit IRC15:11
seaLnepresumably, it sounded like the ramp up hadn't been able to happen as soon as previousy talked about15:26
BhaalAhhhh ok, well thats a bugger15:27
BhaalHas to be hurting15:27
seaLneyeah15:27
*** prpplague <prpplague!~prpplague@rrcs-97-77-26-26.sw.biz.rr.com> has joined #minnowboard15:40
*** sjolley <sjolley!~sjolley@134.134.139.76> has joined #minnowboard15:40
*** macmeck <macmeck!~macmeck@stgt-4d0253ba.pool.mediaWays.net> has joined #minnowboard15:53
*** macmeck <macmeck!~macmeck@stgt-4d0253ba.pool.mediaWays.net> has quit IRC15:58
*** macmeck <macmeck!~macmeck@stgt-4d0253ba.pool.mediaWays.net> has joined #minnowboard16:01
*** macmeck <macmeck!~macmeck@stgt-4d0253ba.pool.mediaWays.net> has quit IRC17:16
*** GPSFan <GPSFan!~kenm@64.92.145.112> has joined #minnowboard18:03
*** bluelightning <bluelightning!~paul@pdpc/supporter/professional/bluelightning> has quit IRC18:04
*** macmeck <macmeck!~macmeck@stgt-4d0253ba.pool.mediaWays.net> has joined #minnowboard18:15
macmeckprpplague: ping18:26
*** prpplague <prpplague!~prpplague@rrcs-97-77-26-26.sw.biz.rr.com> has quit IRC18:33
BryansteinAnyone having any issues with their ethernet device disappearing on the max?18:49
*** prpplague <prpplague!~prpplague@rrcs-97-77-26-26.sw.biz.rr.com> has joined #minnowboard18:51
Bryansteinprpplague, Anyone having any issues with their ethernet device disappearing on the max?18:51
calculusBryanstein: possibly... check your mac address (ifconfig -a)19:06
calculusmake sure it is not all 0s19:06
Bryansteincalculus, lol there is no interface to have even an all zeros mac19:12
Bryansteincalculus, it is gone ;oO19:12
BryansteinAll I have is the loopback interface19:12
prpplagueBryanstein: we have not had any reports of issues19:12
prpplagueBryanstein: there is an option in the bios to disable19:12
prpplagueBryanstein: some of the pcie stuff19:12
prpplagueBryanstein: so it may have gotten disabled19:12
Bryansteinprpplague, I took a glance in there...didn't see anything that jumped out at me19:13
BryansteinIf that is the case...it's also interesting how that might have just disabled itself, which I doubt is the case19:13
Bryansteinprpplague, it's interesting how it corresponds with the rtc loosing time19:15
Bryansteins/loosing/losing19:15
*** macmeck <macmeck!~macmeck@stgt-4d0253ba.pool.mediaWays.net> has quit IRC19:22
*** macmeck <macmeck!~chatzilla@stgt-4d0253ba.pool.mediaWays.net> has joined #minnowboard19:27
macmeckprpplague: saw my question concerning the seacat?19:29
prpplaguemacmeck: yes, but have not had time to look19:30
macmeckprpplague: ah okay19:30
prpplaguemacmeck: i don't recall having an option to override the pintype19:30
* prpplague looks at the schematic19:30
prpplaguemacmeck: ahh indeed!19:31
prpplaguemacmeck: i did not recall having put that in there19:31
prpplaguemacmeck: lucky me19:31
macmeckprpplague: great work then!19:31
prpplaguemacmeck: if you want to solder a two pin header on there you can test19:31
warthog9Bryanstein: haven't seen the main interface disappear19:31
warthog9Bryanstein: can you get me a dmesg from when it happens, and what's in ifconfig -a19:32
macmeckprpplague: gonna give it a try but won't make before the weekend19:32
macmeckprpplague: i'll let you know what comes out19:32
prpplaguemacmeck: dandy19:32
*** hrw <hrw!~hrw@redhat/hrw> has quit IRC20:28
*** hrw <hrw!~hrw@redhat/hrw> has joined #minnowboard20:29
*** mencken_ is now known as mencken20:31
Bryansteinwarthog9, ifconfig -a shows the loopback interface20:35
BryansteinI have dmesg from when the nic was there and now20:35
BryansteinI ran that a gazillion times of course...I had to check to make sure I wasn't crazy before I posted to the mailinglist20:36
warthog9did you post the dmesg output?20:36
* warthog9 didn't see it20:36
Bryansteinwait let me grab it20:37
BryansteinUgg I have to mount my enclosure...the sd I have has /var in tmpfs :oP20:39
warthog9Bryanstein: that's become "normal"20:40
warthog9I don't agree with the principle20:40
warthog9but I've been apparently vetoed20:40
BryansteinWell I do it to save the sd20:41
BryansteinYou should be nice and cp stuff that is needed in var back to disk then copy it back over on boot/shutdown but I dont20:42
*** macmeck <macmeck!~chatzilla@stgt-4d0253ba.pool.mediaWays.net> has quit IRC20:43
Bryansteinhttp://pastebin.com/ZTxBjM8T20:59
Bryansteinwarthog9, there it is20:59
warthog9Bryanstein: it's not showing up on a freshly booted board?21:35
warthog9Bryanstein: what firmware are you on?21:35
warthog9NM21:36
warthog90.7121:36
warthog9BIOS MNW2CRB1.X64.0071.D30.1407181653 07/18/201421:36
warthog9Bryanstein: can you run `lspci | grep -i ethernet` and paste me back the output21:41
*** prpplague <prpplague!~prpplague@rrcs-97-77-26-26.sw.biz.rr.com> has left #minnowboard21:50
*** prpplague <prpplague!~prpplague@rrcs-97-77-26-26.sw.biz.rr.com> has joined #minnowboard22:38
*** prpplague <prpplague!~prpplague@rrcs-97-77-26-26.sw.biz.rr.com> has quit IRC22:54
*** Jazzdude <Jazzdude!6dc03c5d@gateway/web/freenode/ip.109.192.60.93> has quit IRC23:02
*** inflex <inflex!~PLD@122-148-142-6.static.dsl.dodo.com.au> has joined #minnowboard23:16
*** sjolley <sjolley!~sjolley@134.134.139.76> has quit IRC23:29
Bryansteinwarthog9, it's not in there either, you've gotta know I looked there already too23:34
Bryansteinhttp://pastebin.com/r0VpGtmQ23:34
BryansteinThere is the whole lspci, no ethernet...if it aint there in the uefi shell it sure wont be elsewhere23:35
BryansteinBtw warthog9 this is the replacement max...the other I toy with trying to flash coreboot to it23:39
BryansteinI'll give that one more college effort tonight perhaps then I'll leave it be23:40
BryansteinFor some reason FreeBSD 11 current won't boot on the Minnow :o( it should really23:40
BryansteinI've disabled the things that should pose a problem and it still fails to load, arg23:41
warthog9Bryanstein: BSD has issues23:46
warthog9mostly surrounding their surprising lack of UEFI support23:46
warthog9Bryanstein: I've got a friend who's gotten BSD up and running but it was odd how he stumbled over getting it to work23:47
Bryansteinwarthog9, well no that's actually not the problem...uefi works like a champ on FreeBSD23:47
Bryansteinwarthog9, oh really...that I'd be interested to hear23:47
warthog9Bryanstein: I'd try doing a factory reset on the firmware, if your nic still isn't being seen that begs some questions23:47
BryansteinI know there are some acpi issues with Baytrail on FreeBSD. I'll do a video of it almost booting23:48
warthog9Bryanstein: yeah he had to boot it in a slightly odd way for it to not crash on boot23:48
warthog9and no, the BSDs do not have very good UEFI support, and that's what I've been told by the leads of the 3 big BSDs23:48
warthog9and there's a LOT of uefi's out there that have a legacy bios option, which masks the problem for most systems23:49
Bryansteinwarthog9, well FreeBSD has fine uefi support as I run on it 4 laptops which each have uefi support including the one I'm using now. It's an x1 carbon23:49
BryansteinNow OpenBSD...no, NetBSD no...freebsd yes23:49
BryansteinOpenBSD doesn't even do GPT as of yet23:50
warthog9open is practically defunct23:50
BryansteinWell they plan on learning some things from Bitrig but the main reason I want coreboot is for OpenBSD23:50
Bryansteinwarthog9, does your friend use irc?23:51
warthog9probably23:52
warthog9I don't normally ping him via it though23:52
BryansteinI followed the NUC threads online about crashing on boot so I figured the issue with the minnow was the same. Now I didn't disable all that stuff via uefi but I didn't pass a bunch of args to the loader23:52
Bryansteinwarthog9, so the firwmware version that I have is the newest right?23:52
warthog9Bryanstein: newest public23:53
warthog9I've got 0.73 in my boards for testing23:53
Bryansteinwarthog9, does it do anything fancy?23:53
warthog9which is supposed to be the basis for the open source release23:53
Bryanstein.73?23:53
warthog9yeah23:53
BryansteinHmmm I like fancy23:53
warthog9fixes mostly, changes to ACPI by default instead of PCI23:54
warthog9I think that's it23:54
BryansteinOh...so that issue with spi not showing on pci, lol that's the fix?23:54
warthog9uhhhh no23:57
warthog9don't think so...23:57
warthog9Bryanstein: you mean https://bugzilla.yoctoproject.org/show_bug.cgi?id=6627 ?23:57
yoctiBug 6627: normal, Medium, 1.7, dvhart, ACCEPTED , Minnowboard Max fails to load the SPI device23:57
BryansteinYes that one23:58
warthog9well there's two things going on there23:59
warthog9there's your want for spidev to come up on boot23:59
warthog9and the bug in the modules for load / unload23:59
warthog9the former I don't think can actually be done by default23:59

Generated by irclog2html.py 2.11.0 by Marius Gedminas - find it at mg.pov.lt!